Maintenance Release Reminder
Scheduled for May 22, 2025 at 1:30 AM – 1:41 AM
Affects
Neos Web App
Under maintenance from 1:30 AM to 1:41 AM
Neos API
Under maintenance from 1:30 AM to 1:41 AM
Completed
May 22, 2025 at 1:41 AMCompleted
May 22, 2025 at 1:41 AMWe have completed the Neos maintenance window, and the application is now fully accessible. Thank you!
In progress
May 22, 2025 at 1:30 AMIn progress
May 22, 2025 at 1:30 AMMaintenance is now in progress
Completed
May 21, 2025 at 10:03 PMCompleted
May 21, 2025 at 10:03 PMThe downtime for this maintenance window has been updated to a duration of 30 minutes. Thank you!
Planned
May 21, 2025 at 10:03 PMPlanned
May 21, 2025 at 10:03 PMThe downtime for this maintenance window has been updated to a duration of 30 minutes. Thank you!