Release 26.02 was successfully deployed to Production
In progress
March 31, 2026 at 1:30 AM
In progress
March 31, 2026 at 1:30 AM
Maintenance is now in progress
Update
March 31, 2026 at 1:30 AM
Update
March 31, 2026 at 1:30 AM
Hello,
This is a reminder that our new Release is coming soon! To bring you exciting new features and enhancements, we will be performing scheduled maintenance on Monday, March 30th, from 9:30 PM to approximately 1:00 AM ET.
The Neos application will be unavailable to all users from 9:30 PM ET to 10:30 PM ET.
Important: At the end of your workday on March 30th, please be sure to save all work, close all Neos tabs, log out of the system, and close your browser to avoid any disruption.
Thank you for your understanding!
— The Neos Team
Planned
March 31, 2026 at 1:30 AM
Planned
March 31, 2026 at 1:30 AM
To bring you exciting new features and enhancements, we will be performing scheduled maintenance on Monday, March 30th, from 9:30 PM to approximately 1:00 AM ET.
The Neos application will be unavailable to all users from 9:30 PM ET to 10:30 PM ET.
Important: At the end of your workday on March 30th, please be sure to save all work, close all Neos tabs, log out of the system, and close your browser to avoid any disruption.