Scheduled for October 16, 2025 at 1:30 AM – 2:17 AM
Affects
Neos Web App
Under maintenance from 1:30 AM to 2:17 AM
Updates
Completed
October 16, 2025 at 2:17 AM
Completed
October 16, 2025 at 2:17 AM
Our maintenance window has completed successfully.
Update
October 16, 2025 at 1:32 AM
Update
October 16, 2025 at 1:32 AM
Maintenance is now in progress.
In progress
October 16, 2025 at 1:30 AM
In progress
October 16, 2025 at 1:30 AM
To enhance your Neos experience, we will be performing a maintenance update on Wednesday, October 15th at 9:30 PM ET. This update will not cause any downtime, and you may continue using the application as usual.