Scheduled for October 27, 2025 at 8:00 PM – 8:18 PM
Affects
Neos Web App
Under maintenance from 8:00 PM to 8:18 PM
Neos API
Under maintenance from 8:00 PM to 8:18 PM
Updates
Completed
October 27, 2025 at 8:18 PM
Completed
October 27, 2025 at 8:18 PM
Maintenance has completed successfully.
In progress
October 27, 2025 at 8:01 PM
In progress
October 27, 2025 at 8:01 PM
Maintenance is now in progress.
Planned
October 27, 2025 at 8:00 PM
Planned
October 27, 2025 at 8:00 PM
To enhance your Neos experience, a maintenance update will take place on Monday, October 27, at 4 PM ET. There will be no customer downtime or visible UI changes, and users may continue working in Neos without interruption during the update.