Neos - Assembly Software - Neos Application Performance Degradation in some regions – Incident details

All systems operational

Neos Application Performance Degradation in some regions

Resolved
Operational
Started 7 days agoLasted 26 minutes

Affected

Neos Web App

Operational from 2:41 PM to 3:07 PM

Neos API

Operational from 2:41 PM to 3:07 PM

Updates
  • Resolved
    Resolved

    The capacity event affecting certain regions has been mitigated and performance has returned to normal.

  • Identified
    Identified

    We are currently investigating reports of elevated latency and intermittent availability affecting customers in certain regions. Our engineering team has identified the underlying issue and is actively working on mitigation. Users in this region may experience slower response times or brief interruptions when accessing the application during this window.

    No customer data has been lost or compromised. Customers in other regions are not affected.

    We will post the next update within 30 minutes, or sooner if the situation changes. Thank you for your patience.