Scheduled for August 05, 2025 at 1:30 AM – 2:08 AM
Affects
Neos Web App
Under maintenance from 1:30 AM to 2:08 AM
Neos API
Under maintenance from 1:30 AM to 2:08 AM
Updates
Completed
August 05, 2025 at 2:08 AM
Completed
August 05, 2025 at 2:08 AM
Our maintenance update completed successfully
In progress
August 05, 2025 at 1:30 AM
In progress
August 05, 2025 at 1:30 AM
Maintenance is now in progress
Planned
August 05, 2025 at 1:30 AM
Planned
August 05, 2025 at 1:30 AM
To enhance your Neos experience, a maintenance update is scheduled for Monday, August 4th at 9:30 PM ET. There will be no customer downtime, and users can continue using the application as usual during the update.